¿QUÉ ES LDAP?

¡Buenas tardes!

Esta semana he tratado la herramienta LDAP. LDAP viene de las siglas de “Lighweight Directory Access Protocol”, es una base de datos jerárquica orientada a objetos, dónde las clases no tienen métodos, sólo atributos, a la cual se realizan consultas de registros con usuarios y perfiles.

Las características de LDAP frente a otros servidores de directorios como X.500, son las siguientes:

  • Permite varias peticiones en curso
  • Existe un formato para exportar información entre servidores de directorios, conocida como LDIF
  • Tiene autenticación muy rápida, y se puede utilizar Kerberos en este proceso.
  • El acceso de LDAP mediante JAVA, se realiza por JNDI (“Java Naming Directory Interface”). Es una sintaxis propia, diferente a SQL.

El proceso de configuración que he seguido para instalar el servicio OpenLDAP es siguiendo una serie de pasos:

Comenzamos instalando el servidor LDAP en nuestra máquina servidora con: apt-get install slapd ldap-utils.

Cuando hayamos puesto la clave que deseemos, configuramos el servidor LDAP con: dpkg-reconfigure slapd Cuando nos pregunten si deseamos omitir la configuración de OpenLDAP, decimos que NO, después introduciremos el dominio DNS que deseemos (por ejemplo micasa.edu), el motor de base de datos yo he seleccionado el que está por defecto el HDB porque es totalmente jerárquica, al pedirnos si puede borrar la base de datos al ser la primera vez le podemos dar que (aunque habría que dar que NO si ya está hecha, ya que sino se elimina).

Cuando nos pide si queremos mover otra base de datos, en caso de tener otra dar que sí, en mi caso como quiero empezar una desde cero, pues le doy a NO. Finalmente, dejamos la utlima opción por defecto, ya que NO queremos utilizar el protocolo LDAPv2, vamos a utilizar el protocolo LDAPv3.

Creamos un archivo ldif para crear usuarios y grupos: por ejemplo usergroup.ldif

dn: ou=personas,dc=casa,dc=edu
objectClass: organizationalUnit
ou: personas

dn: ou=grupos,dc=cum,dc=edu
objectClass: organizationalUnit
ou: grupos

* en dc ponemos casa y edu, porque se trata del dominio DNS: miequipo.casa.edu

A continuación, introducimos el comando en el terminal: ldapadd -x -D cn=admin,dc=casa,dc=edu -W -f usergroup.ldif  Nos pedirá una contraseña y si la introducimos correctamente, aparecerán añadidas 2 nuevas entradas en el directorio LDAP.

CONFIGURACIÓN VISORES LDAP

Tenemos dos importantes visores, a saber:

PHPLDAPADMIN

Instalamos el paquete siguiente: apt-get install phpldapadmin

Trae como servidor por defecto “example.com”, para cambiarlo nos metemos en el archivo de configuración y cambiamos las líneas “dc=example,dc=com” por “dc=cum,dc=edu”. Para modificar el archivo introducimos: nano /etc/phpldapadmin/config.php

JXPLORER

Nos descargamos de la página oficial de JXplorer, y cuando tengamos el paquete en nuestra carpeta, le damos permisos y ejecutamos del siguiente modo:

  • ls -l jxplorer-3.3.02-linux-installer.run
  • chmod a+x jxplorer-3.3.02-linux-installer.run
  • ./jxplorer-3.3.02-linux-installer.run
  • cd /opt/jxplorer/
  • ./jxplorer.sh

Mi primer trabajo

Este fin de semana he tenido mi primer trabajo, sí temporal, pero algo es algo. Duró tres días y se trataba de ser azafata o “personal auxiliar” de un evento, en este caso era de Telefónica, tenía que explicar a las personas de Badajoz algunos servicios que ofrecía. Me encantó la experiencia, conocí a gente estupenda y me reí muchísimo. Además de que experiencias de estas de vez en cuando te abren la mente. Con la cosa de trabajar en esto me informé y descubrí el blog de telefónica, que la verdad he estado leyendo algunos artículos y está muy bien, os lo dejo por si os interesa:

http://blogthinkbig.com/cat/innovacion-2/

Había 7 puestos, yo expliqué el de reconocimiento de Imágenes con una aplicación para smartphones, otros contaron servicios sobre machine-to-machine, internet de las cosas, servicios para ayudar a personas mayores y discapacitados e incluso herramientas de marketing con reconocimiento facial.

Además, conocí a personas en el mundo laboral y ya tengo notas mentales para hacer cuando acabe la carrera y empiece a trabajar, que son: hacerme un about.me que es como una página para describirte a ti mismo en la red, tener mi perfil de Linked.in en el 3º nivel y mejorar muchísimo más mi inglés. Siempre he pensado en irme un año a Inglaterra o Irlanda, pero en realidad me da un poco de miedo, pero después este fin de semana me ha dado un empujoncito a decidirme más fuertemente a esta idea, aunque claro… primero es lo primero acabar Telemática.

telefonica

Para finalizar quería mencionar a Alejandro Suarez, que es un empresario y emprendedor, lo vi en una conferencia de Emprendedores el año pasado y hablaba de una manera tan real, autentica y con mucha fuerza que me quedé pensando mucho en sus palabras. Investigué sobre él y lo sigo en twitter y además me leí su libro “Desnudando a Google”, muy recomendable por cierto. Cuenta muchos secretos de Google, cómo fue creciendo la empresa, cuáles son sus métodos para hacerse valer frente a otras empresas y su punto débil. El otro día, puso un twitter con cursos gratuitos para emprendedores, yo actualmente estoy haciendo uno, y quería compartir el enlace:

http://unimooc.com/courses/cursos-emprendedores/

Además, he visto que en uno de los cursos expone Alberto Elías que ha fundado su empresa y tan sólo está en bachillerato. Me ha sorprendido verlo en el curso, ya que yo vi como expuso en Cáceres sobre el emprendimiento, el mismo día de Alejandro Suarez.

Aquí acabo, saludos y que tengan feliz semana.

X Edición Bellota Valley

Quiero contar mi experiencia en la última charla a la que asistí, se trata de la Xº convocatoria del Bellota Valley, se presentó en el hotel Velada en Mérida. Fue la primera vez que asistí a ese evento. Se trata de una serie de personas de Extremadura interesadas por la tecnología. Aquí os pongo un video que lo explica que es el Bellota Valley, que es un foro tecnológico que no lo lleva nadie en especial sino que son voluntarios que se preparan una presentación.

Como dijeron el Bellota Valley son los padres. Hubo una serie de ponencias y una parte de “Networking” que era una pequeña presentación de los participantes. Ahí tuve mi minuto y medio de gloria, en el que pude decir: “Soy estudiante de la Universidad de Extremadura, en el que estoy haciendo ahora el proyecto de fin de grado sobre Domótica con Arduino y Android”.

Ese día estaba un poco tocada de salud, y no tenía muchas ganas de entablar conversación, aunque luego me arrepentí de no haberlo hecho. En su lugar, estuve con dos compañeros de Universidad de otra carrera pensando qué podríamos hacer nosotros con nuestro futuro. El tema a tratar en las ponencias era el “Internet de las cosas”. Empezó haciendo una introducción Francisco Morcillo, he visitado su blog después de la charla, y para conceptos generales sobre “Smart City” no está mal, os dejo el enlace:

http://smartcitymb3.wordpress.com/

Hubo ponencias sobre la salud, módulos inalámbricos, pero los conceptos que más me llamaron la atención fue machine-to-machine de la empresa de Juan Miguel.

Hace tiempo empecé con este blog, tenía claro que quería hacerme una plataforma. Pero ha sido gracias a un miembro del público de ese día, Ángel Alegre García, el que me ha hecho cambiar la forma de pensar y de encaminar un blog. Leí algunas entradas por curiosidad y la verdad es que me ha enganchado su historia y su forma de ver la vida, en casi todos los aspectos le doy la razón y además aconseja libros y herramientas muy útiles. Sin duda aconsejo que le echen un vistazo:

http://viviralmaximo.net/

Ahora pienso que un blog sirve para mostrar tu personalidad y a la vez mostrar lo que haces, quien eres. Y yo antes no lo tenía tan claro, solo escribía en plan “tutoriales”. A continuación os dejo una fotografía de la sala.

Imagen

CONFIGURACIÓN FRAME-RELAY

Frame-Relay es una técnica de comunicación mediante retransmisión de tramas para redes de circuito virtual. Se diseñó a finales de los 80 y principios de los 90. Opera en el nivel físico y de enlace, ofrece mayores velocidades y no es tan cara como otras tecnologías WAN. Sólo tiene detección de errores en el nivel de enlace, no hay control de flujo ni control de errores. Tiene un tamaño de trama de 9000 bytes. Se diseñó para ofrecer una rápida transmisión para medios fiables y además, ofrece control de congestión y calidad de servicio (QoS).

A continuación vamos a ver como configurar esta tecnología en una red de tres maneras distintas:

  •  Configuración de Frame Relay como una red Broadcast.

Para este ejemplo he utilizado dos routers con un conmutador Frame-Relay. El primer paso es configurar este dispositivo. Por el puerto 1 de entrada tenemos el camino DLCI 102, y como salida por el puerto 2 el camino DLCI 201.

Configuración Frame-Relay Broadcast

Configuración Frame-Relay Broadcast

A continuación, configuramos los dos routers de la siguiente manera:

ROUTER R1

interface Serial1/0

  • ip address 10.10.10.1 255.255.255.0
  • encapsulation frame-relay
  • frame-relay lmi-type ansi
  • ip ospf network broadcast
  • frame-relay map ip 10.10.10.2 102 broadcast
  • frame-relay interface-dlci 102

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0

ROUTER R2

interface Serial1/0

  • ip address 10.10.10.2 255.255.255.0
  • encapsulation frame-relay
  • frame-relay lmi-type ansi
  • ip ospf network broadcast
  • frame-relay map ip 10.10.10.1 201 broadcast
  • frame-relay interface-dlci 201

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0

Como vemos, hemos configurado OSPF para el encaminamiento, y dentro del Serial correspondiente añadimos los comandos para Frame-Relay. Una forma de probar que funciona correctamente es con el comando:

#debug frame-relay packet interface Serial1/0

  • Configuración a través de subinterfaces punto a punto 

Utilizamos la misma configuración que en broadcast, y los mismos caminos en el conmutador Frame-Relay. Pero varía los comandos introducidos en los routers R1 y R2, que ahora serían de la siguiente manera:

ROUTER R1

interface Serial1/0

  • encapsulation frame-relay
  • frame-relay lmi-type ansi

interface Serial1/0.1 point-to-point

  • ip address 10.10.10.1 255.255.255.0
  • frame-relay interface-dlci 102

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0

ROUTER R2

interface Serial1/0

  • encapsulation frame-relay
  • frame-relay lmi-type ansi

interface Serial1/0.1 point-to-point

  • ip address 10.10.10.2 255.255.255.0
  • frame-relay interface-dlci 201

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0
  • Configuración a través de subinterfaces punto-multipunto

En este ejemplo vamos a utilizar 3 routers en lugar de 2. Y la configuración del conmutador Frame-Relay cambia con respecto al anterior. Por el puerto 11 de entrada tenemos el camino DLCI 102, y como salida por el puerto 22 el camino DLCI 201. Por el mismo puerto 11 tambien tenemos el camino de entrada DLCI 103, y como salida el puerto 33 con camino DLCI 301.

Configuración Frame-Relay Punto-Multipunto

Configuración Frame-Relay Punto-Multipunto

La configuración de los routers también varía, siendo ahora de la siguiente manera:

ROUTER R1

interface Serial1/0

  • encapsulation frame-relay
  • frame-relay lmi-type ansi

interface Serial1/0.1 multipoint

  • ip address 10.10.10.1 255.255.255.0
  • ip ospf network broadcast
  • frame-relay map ip 10.10.10.2 102 broadcast

interface Serial1/0.2 multipoint

  • ip address 11.11.11.1 255.255.255.0
  • ip ospf network broadcast
  • frame-relay map ip 11.11.11.2 103 broadcast

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0
  • network 11.11.11.0 0.0.0.255 area 0

ROUTER R2

interface Serial1/0

  • ip address 10.10.10.2 255.255.255.0
  • encapsulation frame-relay
  • ip ospf network broadcast
  • frame-relay map ip 10.10.10.1 201 broadcast
  • frame-relay lmi-type ansi

router ospf 1

  • network 10.10.10.0 0.0.0.255 area 0

ROUTER R3

interface Serial1/0

  • ip address 11.11.11.2 255.255.255.0
  • encapsulation frame-relay
  • ip ospf network broadcast
  • frame-relay map ip 11.11.11.1 301 broadcast
  • frame-relay lmi-type ansi

router ospf 1

  • network 11.11.11.0 0.0.0.255 area 0

EmoSPARK – Una consola inteligente

Mirando cosillas por Internet he encontrado la primera consola inteligente, me ha llamado la atención y quería compartirlo. Es una consola que permite la interacción con el usuario, para ello cuenta con una unidad de procesamiento de emociones (EPU) y la combinación del gráfico del perfil emocional (EPG) con el reconocimiento facial.

http://www.indiegogo.com/projects/emospark-first-a-i-home-console

Oliendo curiosidades

Acabo de leer dos noticias (www.teinteresa.es), a cual más novedosa. Es increíble cómo evoluciona la tecnología. La primera es sobre el envío y recepción de olores, se trata de un dispositivo “Scentee” que se conecta a la toma de auriculares. Permite enviar y recibir olores, y para ello cuenta con un cartucho con capacidad de expulsar aromas.

Y la segunda noticia es sobre la venta de prendas cuya tela está preparada para proteger a las personas de las radiaciones de las ondas de móviles y radiofrecuencias. Estas telas están hechas en Alemania. Aunque todavía estas prendas están en proceso de desarrollo y no se sabe con certeza sus efectos.

De cualquier manera, estas dos novedades nos hacen pensar en que estamos evolucionando, en constante desarrollo y que cosas que hace unos años eran impensables, ahora tienen precio y están disponibles.

MPLS “MULTIPROTOCOL LABEL SWITCHING”

Actualmente estoy trabajando con la tecnología MPLS y quería hacer una introducción de ella. Para empezar, decir que fue creada por IETF (Internet Engineering Task Force) y en el RFC3031 está descrito el funcionamiento de esta tecnología. MPLS no se desarrolló para sustituir a Frame-Relay o ATM, sino para complementarlas, pero al final, debido a que es más fiable, tiene mayor rendimiento y menos costos con mayor eficiencia, poco a poco se está expandiendo como tecnología única.

MPLS opera entre la capa de enlace de datos y capa de red del modelo OSI, y es un estándar IP de conmutación de paquetes. Se desarrolló para unificar la conmutación de paquetes y circuitos, ya que el tráfico que lleva son tanto paquetes IP (paquetes) como VoIP (circuitos).

Como su nombre indica, MPLS es una tecnología basada en etiquetas. Son las que permite redireccionar el tráfico por los router. Esta etiqueta (32 bits) se compone de los siguientes campos:

  • TTL: tiempo de vida –> 8bits
  • Valor de la etiqueta –> 20bits
  • Experimental –> 3bits
  • Bit que permite saber que etiqueta es la más antigua, esto se sabe porque está a 1 si es la más antigua. –> 1bit

Hay una serie de conceptos importantes que hay que conocer:

  • LER “Label Edge Router”: Son los routers que se situan en la entrada y salida de la configuración MPLS. Cuando nuevo tráfico quiere ingresar en la red MPLS, a ese router se le llama “Router de Ingreso”, mientras que al router que permite salir el trafico de la red MPLS se le denomina “Router de Regreso”.
  • LSR “Label Switching Router”: Son todos los routers que permiten configurar MPLS y están en dicha red.
  • LSP “Label Switched Path”: Es el camino que sigue el tráfico MPLS.
  • LDP “Label Distribution Protocol”: Es el protocolo que trae por defecto para encaminar etiquetas. Hay dos protocolos LDP que lo promueve Cisco y RSVP (“Resource Reservation Protocol”) que lo fomenta IETF. LDP está más en desuso porque RSVP permite ingeniería de tráfico, y es el que utilizamos para la configuración de red MPLS.

ConfiguracionMPLS

Todos los routers son LSR y LER solamente son los routers que tienen un switch directamente conectado.

Para la configuración MPLS:

Antes de configurar los parámetros MPLS, debemos configurar correctamente todas las interfaces que vayamos a utilizar, así como las interfaces de Lookback.
Después, en el modo de configuración global introducimos:

  • ip cef [distributed]
  • mpls traffic-eng tunnels 

Seguidamente, configuramos OSPF y añadimos:

  • mpls traffic-eng tunnels
  • mpls traffic-eng router-id loopback0
  • mpls traffic-eng area ospf-area 

En cada interfaz en la que vayamos a utilizar MPLS escribimos:

  • mpls traffic-eng tunnels
  • ip rsvp bandwidth Kbps (Optional)
  • mpls traffic-eng attribute-flags attributes (Opcional) 

Desde el modo de configuración global, creamos una nueva interfaz Tunnel:
interface Tunnel0

  • ip unnumbered loopback0
  • tunnel destination ID_Router_Final
  • tunnel mode mpls traffic-eng
  • tunnel mpls traffic-eng bandwidth 10
  • tunnel mpls traffic-eng autoroute announce 

También existen otros comandos como:

  • tunnel mpls traffic-eng bandwidth Kbps
  • tunnel mpls traffic-eng priority prioridad [hold-pri]
  • tunnel mpls traffic-eng affinity propiedades [mask

Dentro de nuestra interfaz Tunnel creamos los diferentes “sub-túneles” así:

  • tunnel mpls traffic path-opt Prioridad explicit name nombreT end 

Desde el modo de configuración global, especificamos la ruta de los “sub-túneles”:

  • ip explicit-path name nombreT
  • next-address X.X.X.X
  • next-address X.X.X.X